不再兼容IE8及其以下浏览器

最近更换VPS的时候顺道更新了整个wordpress 的themes。
这次直接基于官方默认的themes上做修改,主要是把老的风格做了近一步的优化,显得更加简洁和接近扁平化风格。官方themes是HTML5书写的,所以比较完美的支持多个客户端情况,不过同时他也放弃了IE8及其以下版本的老IE浏览器。
本来想自己增加一些兼容性代码,让其支持IE8,但是因为调试环境都没,每次都是线上直接调试,又麻烦又费事。而且,blog 一直都很清淡,就算关注blog的也几乎是mac用户和前端同学,那么 IE8 算个啥,就让他消逝在风中吧:)

PS:
IE11+win10 也是够了,如果不加入强制使用当前版本渲染,那么他会拿IE7来渲染,并且,晚上给的 代码还是不支持IE11的,需要修改为如下代码:
<meta http-equiv=”X-UA-Compatible” content=”IE=edge,chrome=1″ />,content=”IE=edge” ,而不是content=”edge”

Leave a Reply

Your email address will not be published. Required fields are marked *